Communauté Play-Arena


    PipBoy2 Beta 1

    Partagez
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    PipBoy2 Beta 1

    Message par Stouf le Ven 13 Mar 2009 - 2:57

    Et voila... la première version beta du PipBoy2...

    Donc ce qui est nouveau :
    - retour au graphisme RoG
    - graphes cpu et mémoire en page clock-2
    - témoin d'overclocking en page clock-2
    - Résolution d'affichage en page gaming-2
    - systeme de gestion des langues facile à 'localizer'
    - PipBoy Companion, pour se faciliter la configuration : plus besoin d'aller trifouiller dans le code, tout se fait depuis le PipBoy, ou en lancant Companion.exe.
    - Un menu d'options, succint pour le moment mais efficace, j'attends vos éventuelles idées Smile
    - Gestion de SP2 pour accéder au menu ou en sortir. Dans le menu, on navigue avec HAUT/BAS et on valide avec SP1
    - Systeme de lancement de Everest et Fraps au démarrage + controle d'erreurs basique.

    Pour la gestion de l'overclocking, ce sera pour plus tard... J'ai pas envie de contribuer au cramage d'un ordi qui est pas le mien Smile

    Vous trouverez dans l'archive un PDF explicatif.
    Dans ce pack 'scriptonly', il y a tout le necessaire au script : le script, le companion, les traduc anglais et francais, les 3 polices nécessaires, le driver et les plugins lcdhype nécessaires.

    J'espere que cette version vous plaira, j'y ai passé un temps assez hallucinant.
    Si j'ai oublié des choses que vous m'aviez demandé, désolé, j'ai pas pu forcément me souvenir de tout ou tout mettre en place... Hésitez pas à demander, c'est encore qu'une beta qui peut encore être modifiée Smile

    Le dernier gros bug restant est qu'on ne peut toujours pas controller le script en mode gaming + températures seuil 1, les raccourcis ne veulent rien savoir... J'avoue sècher un peu sur ce point précis Sad

    Amusez vous bien Wink

    PipBoy2 Beta1 :
    http://www.megaupload.com/?d=L73J28DR

    Fantomette

    Maltraiteur de Betas

    Nombre de messages : 36
    Age : 26
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Fantomette le Ven 13 Mar 2009 - 18:21

    Salut Stouf !

    Content de savoir que tu continues à améliorer tes version.
    Jusqu'à présent j'avais la PipBoy 1-13-13, et félicitation, je n'ai rencontré aucun bug !

    Je vais télécharger ta nouvelle version, je posterais si je trouve des bug, sinon c'est qu'il n'y en a pas Razz.


    Merci, Bye.


    EDIT :

    Alors plusieurs choses :


    Comme tu peux le voir, sur cette image l'heure numérique se superpose sur l'horloge, c'est assez gênant.
    Le temps du démarrage (le 1er) marche très bien, mais le temps d'activité (le 2eme) bug. Quand je ne bouge pas ma souris pendant Xsecondes, ces Xsecondes se rajoute au temps d'activité au lieu de repartir ou il c'était arrêter. (Ex : Tempe d'activité 20mn 05s - je bouge pas ma souris pendant 10 s - la je la bouge et le temps passe tout de suite a 20mn 15s a la place de 20mn 06s)



    Quand je change de MOD, il ne s'affiche pas. (Normal / Gaming etc...)



    Les chiffres dans les petites cases CPU et MEM restent a leur - maximum ou moyenne ? - et ne bougent plus, sauf si ces chiffes augmente.
    Est-ce normal ?



    Le nombre de FPS - max ou moyen ? - ne s'affiche pas, il reste a 0.



    Avoir ajouter la résolution dans "screen" je trouve ça super bien !
    Sinon RAS sur les autres mod.


    Voila je reposterais si je trouve d'autre bug.
    A bientôt pour une nouvelle version. Smile


    EDIT 2 :

    Je n'ai pas tout desinstaller/reinstaller, j'ai juste copier et remplacer les dossiers Controler, Plugin et Script, puis lancer le script.
    Ca vient peut etre de ca, si tu pouvais poster un pack script + plugin + tout les bidules + lcdhype, (sans fraps ni everest), je réessaierais de l'installer.
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Stouf le Ven 13 Mar 2009 - 21:37

    Hello fantomette ! Ravi d'avoir de tes nouvelles !

    Pour tes problemes (tous), je te conseille de lancer le Companion.exe qui se trouve dans le dossier du pipboy.
    De la, configures tout comme il faut (surtout le 1er onglet, ou tu choisis le fichier de langue), et redemarres le script, ca devrait etre bon...

    J'ai justement rajouté le Companion pour simplifier sa configuration, mais il faut le savoir Wink

    Pour ton souci du temps 'actif', il y a une marge d'erreur qui permet de ne pas compter les 10 premieres secondes d'inactivité si le pc reprend une activité dans ce laps de temps (vois tu ce que je veux dire ? ^^)
    Donc oui, si tu restes inactive disons... 8 secondes, alors le temps 'actif' fera un saut de 8 secondes. Ca répond à ta question ou pas ?

    Tiens moi au courant !

    EDIT : une fois configuré avec le Companion, tu peux reconfigurer ce que tu veux ou recharger le PipBoy depuis le menu d'options, que tu actives/desactives avec SP2. Dans ce mode, tu valides tes choix avec SP1 et tu navigues avec UP-DOWN

    EDIT2 : les valeurs en tout petit sont les temperatures maximales.

    Fantomette

    Maltraiteur de Betas

    Nombre de messages : 36
    Age : 26
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Fantomette le Ven 13 Mar 2009 - 21:51

    Pour tes problemes (tous), je te conseille de lancer le Companion.exe qui se trouve dans le dossier du pipboy.
    De la, configures tout comme il faut (surtout le 1er onglet, ou tu choisis le fichier de langue), et redemarres le script, ca devrait etre bon...

    Merci, modifier le chemin d'accès du fichier de langue a résolu tout les problèmes sauf un. (Quoique je ne sais pas si c'est un problème)



    Les chiffres dans les petites cases CPU et MEM restent a leur - maximum ou moyenne ? - et ne bougent plus, sauf si ces chiffes augmente.
    Est-ce normal ?


    Voilap.


    EDIT :


    EDIT2 : les valeurs en tout petit sont les temperatures maximales.

    Ok, merci. Smile

    Sanka

    Graine de développeur

    Nombre de messages : 29
    Age : 36
    OS Principal : Vista
    Script OLED : Sanka

    Re: PipBoy2 Beta 1

    Message par Sanka le Sam 14 Mar 2009 - 5:09

    Sur le coup, j'ai pas compris pourquoi il marchait qu'à moitié, je m'apprêtais à relire le script sous toutes ses coutures pour retrouver les chemins à changer pour les images manquantes, quand j'ai décidé de relire le post de Fantomette : En effet, redéfinir le chemin vers le fichier lang.fr a tout réglé Smile

    Mais alors là, franchement, chapeau ! Le script en lui même est très bien fait, mais là où je suis vraiment jaloux (d'ailleurs tu fais ch*** ^^), c'est le companion.exe, c'est vraiment, mais alors vraiment génial ! Pour mon script, j'avais déjà réfléchi à modifir la structure pour mettre toutes les variables configurables ou les chemins à changer, ou encore les textes à traduire sur une page du script dédiée (mais trop la flemme^^), mais là, c'est vraiment le top !
    Au fait j'ai pas eu encore le temps, mais t'inquiète, j'oublie pas de faire les icônes manquants Wink

    Bravo aussi pour ton PDF, digne d'un programme qu'on pourrait trouver dans le commmerce !
    Stouf a écrit:
    Pour la gestion de l'overclocking, ce sera pour plus tard... J'ai pas envie de contribuer au cramage d'un ordi qui est pas le mien Smile

    J'ai une petite idée pour ça :
    Tu pourrais mettre une option dans le companion.exe pour l'activer l'affichage du menu O/C, ou pas. D'origine, il serait désactivé, et au dessus de la case permettant de l'activer dans le companion, tu mettrais un message du genre paquet de clope : L'O/C Tue, l'O/C rend impuissant, en aucun cas je ne peux être tenu responsable, etc...^^

    PS : Une option qui serait pas mal à implémenter dans le companion, ça serait l'activation/désactivation de chaque popup séparément :
    Sur mon PC, je ne fais pas d'O/C, du coup, c'est mon PC qui gère entièrement mon horloge, et du coup le popup des Mhz apparît toutes les 5 secondes.

    EDIT : Je me lance sur les critiques (bugs) Wink
    -Quand le screensaver est activé (ou que l'OLED est éteint), je vois toujours s'afficher le popup de la fréquence CPU.
    -Lorsque je règle l'affichage des popup sur 1seconde dans companion, aussitôt que le popup fréquence CPU s'affiche, je vois ensuite apparaitre le popup volume, qui reste sur 0%, alors que je suis à 100%, et j'entends des petits bips en continu, le popup ne voulant plus cesser de s'afficher, sauf pour laisser place au popup fréquence CPU... Je rappelle que je suis sous vista32 (donc le plugin du son n'est pas correctement géré), avec la version 28C du G50 (C2D P8400, résolution 1440x900) PS : Quand ce bug apparait, impossible de reprendre le controle de l'OLED pendant quelques minutes, l'écran reste bloqué sur le popup du son.
    -Un autre bug que je n'ai pas encore essayé de reproduire plusieurs fois : J'étais sur l'écran de configuration du companion, je uis resté environ 2 min sans rien toucher (il n'a pas basculé en veille, jusque là je suppose que c'est normal), et quand j'ai voulu naviguer vers le bas dans le menu, je voyais toujours les flèches sur le côté, mais plus les écritures, je pense qu'il doit y avoir un problème avec le screensaver, j'essaierai de le reproduire pour être fixé...


    C'est tout pour le moment, je t'avais prévenu, j'aime bien triturer les programmes (pas que le tien, tous en général, d'ailleurs je me demande si je suis bien normal... Razz)
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Stouf le Sam 14 Mar 2009 - 15:55

    -Quand le screensaver est activé (ou que l'OLED est éteint), je vois toujours s'afficher le popup de la fréquence CPU.
    It is not a bug, it's a feature : les popups restent actifs pendant le screensaver, pour 2 raisons : 1) pour éviter au script de perdre les pedales s'il y a un changement pendant le screensaver, 2) Pour garder un visu de ce qui se passe même quand le screensaver est actif.

    -Lorsque je règle l'affichage des popup sur 1seconde dans companion, aussitôt que le popup fréquence CPU s'affiche, je vois ensuite apparaitre le popup volume, qui reste sur 0%, alors que je suis à 100%, et j'entends des petits bips en continu, le popup ne voulant plus cesser de s'afficher, sauf pour laisser place au popup fréquence CPU... Je rappelle que je suis sous vista32 (donc le plugin du son n'est pas correctement géré), avec la version 28C du G50 (C2D P8400, résolution 1440x900) PS : Quand ce bug apparait, impossible de reprendre le controle de l'OLED pendant quelques minutes, l'écran reste bloqué sur le popup du son.
    Je pense que c'est clairement à cause du plugin volume qui ne fonctionne pas bien sous vista (parfois 'volumechange' passe à 1 sans raison... A part virer les popups de volume, je vois pas trop d'autre solution... (mettre une variable de config Vista/XP, mais ca risque d'être un gros boulot. Je vais voir)

    -Un autre bug que je n'ai pas encore essayé de reproduire plusieurs fois : J'étais sur l'écran de configuration du companion, je uis resté environ 2 min sans rien toucher (il n'a pas basculé en veille, jusque là je suppose que c'est normal), et quand j'ai voulu naviguer vers le bas dans le menu, je voyais toujours les flèches sur le côté, mais plus les écritures, je pense qu'il doit y avoir un problème avec le screensaver, j'essaierai de le reproduire pour être fixé...
    Une fois le script lancé, normalement on lance le Companion par l'intermédiaire du menu d'options (SP2)
    Une fois lancé, le script se met en 'pause', avec le message 'En attente du PipBoy Companion', avec en effet les 2 fleches à gauche. Quand tu refermes le Companion, le script relance la séquence de configuration.
    Ca fait pas ca chez toi ?
    J'ai essayé de reproduire le bug (companion est lancé depuis 10 bonnes minutes, pas de bug, le script est bien en pause)

    Tu pourrais mettre une option dans le companion.exe pour l'activer l'affichage du menu O/C, ou pas.
    Pas bête, je vais étudier ca Smile

    Une option qui serait pas mal à implémenter dans le companion, ça serait l'activation/désactivation de chaque popup séparément
    Ca aussi c'est un gros boulot, mais pourquoi pas, ca peut etre une option interessante...

    Merci pour vos retours les zamis, et continuez de malmener mon script, il en a bien besoin ^^

    Sanka

    Graine de développeur

    Nombre de messages : 29
    Age : 36
    OS Principal : Vista
    Script OLED : Sanka

    Re: PipBoy2 Beta 1

    Message par Sanka le Dim 15 Mar 2009 - 21:47

    Stouf a écrit:Une fois le script lancé, normalement on lance le Companion par l'intermédiaire du menu d'options (SP2)
    Une fois lancé, le script se met en 'pause', avec le message 'En attente du PipBoy Companion', avec en effet les 2 fleches à gauche. Quand tu refermes le Companion, le script relance la séquence de configuration.
    Ca fait pas ca chez toi ?
    J'ai essayé de reproduire le bug (companion est lancé depuis 10 bonnes minutes, pas de bug, le script est bien en pause)

    Tout fonctionne comme tu décris, et je n'arrive plus à reproduire ce bug... En fait, j'étais allé sur la page de config en appuyant sur SP2, puis je n'aivas rien fait pendant environ 2 minutes (donc je n'ai pas lancé le companion)... Ensuite, j'ai voulu aller vers le bas dans le menu de config, et là, tout a disparu, il ne restait plus que les flèches. En parallèle, pendant les 2 minutes d'attente, je lisais un mail sur Gmail, donc je n'ai absolument rien touché, ni la souris, ni le clavier. C'est pour ça que je pensais que ça venait d'un bug au niveau du script de mise en veille, mais apparemment c'était pas ça, à suivre (ou à classer si ça le refait plus^^)...

    Je précise que ce ne sont absolument pas des critiques, j'essaie juste de trouver les parties du script pouvant poser problème sur une configuration différente de celle sur laquelle tu l'as développé Wink

    Au fait, un bug qui n'a rien à voir : je suis passé sur IE8, la bêta, et depuis, je dois me logger systématiquement sur ton forum quand je viens via le lien reçu par mail (je coche bien "connexion auto" pourtant), sinon je suis en tant qu'invité ! Et sur les autres forums que je fréquente, je suis bien reconnu pourtant... A part ça, cette bêta a quand même plusieurs petits problèmes, je suppose qu'ils les résoudront peu à peu, mais je t'en parle quand même au cas ou ça te donne envie de trifouiller dans ton code Razz
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Stouf le Lun 16 Mar 2009 - 0:48

    Je précise que ce ne sont absolument pas des critiques, j'essaie juste de trouver les parties du script pouvant poser problème sur une configuration différente de celle sur laquelle tu l'as développé
    No problem, pas besoin de préciser, une beta est faite pour ca Wink

    Euh par contre... IE8... Déja j'évite IE comme la peste, alors le 8 et en beta... ^^
    Firefox3, par contre... pas de probleme pour rester logué auX forumS, quels qu'ils soient... Wink

    Alleeeeez Sanka.... Laisses toi aller, essaies un browser qui browse Very Happy
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Stouf le Mer 18 Mar 2009 - 2:49

    Une option qui serait pas mal à implémenter dans le companion, ça serait l'activation/désactivation de chaque popup séparément
    Voila, ca c'est fait.

    Les raccourcis ne fonctionnent pas en mode Gaming
    Ca aussi, normalement c'est réglé
    avatar
    johnat

    Maltraiteur de Betas

    Nombre de messages : 534
    Age : 29
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par johnat le Sam 28 Mar 2009 - 20:21

    Salut, me revoila sur pipboy...
    Bon je n'arrive toujour pas à le faire fonctionner.
    Il me met Problème avec everest.
    mais surtout il n'y a rien qui se lance au démarage...
    Je comprend pas se qui se passe, j'ai pourtant suivi les instructions à la lettre, et j'ai aussi enleve le programme asus...

    Aussi, j'ai vu que tu avais mis une case de fréquence cpu dans le compagnon....
    C'est pour over colker le cpu, ou c'est juste une référence ?
    BOn je réinstale tous... et je te dit quoi..
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Stouf le Sam 28 Mar 2009 - 20:31

    "Probleme avec Everest" signifie que :
    - soit il n'a pas démarré,
    - soit il ne lit pas / n'exporte pas les températures.

    Lorsqu'une telle erreur se produit, le PipBoy s'arrete la jusqu'a ce que le probleme soit résolu.

    Tu es bien sur de l'avoir bien configuré, et d'avoir lancé et configuré le Companion la premiere fois ? (je pense que oui puisque tu as le message d'erreur)
    Vérifies le chemin d'Everest dans le Companion,
    Vérifies les paramètres d'exportation des données dans Everest.

    Au fait : tu utilises bien la version Utltimate d'Everest ? c'est obligatoire.

    La case de fréquence CPU sert à activer/désactiver le popup de changement de fréquence CPU. Il ne sert pas à overclocker (pas encore dumoins ^^)

    Je dois bouger une petite demi-heure, fais tes tests d'ici la, et je te reprends en revenant Wink
    avatar
    johnat

    Maltraiteur de Betas

    Nombre de messages : 534
    Age : 29
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par johnat le Sam 28 Mar 2009 - 20:59

    QUand tu dit cocher la case 1 , décocher le reste...
    cela veux bien dire que tu coche la case Système, que tu décoches toutes les cases sauf vitesse d'horloge du CPU...
    puis tu coches selement les cases processeur et GPU dans températures ?
    Fraps se lance bien... toute est bien configuré... il n'y a que everest ultimate qui ne fonction pas...
    DIt j'y pense , vu que j'ai perdu l'overclok CPU, est ce que tu peux me donner ta configuration (les deux valeurs que tu as rentré sur setfsb et le clock generator... j'ai pas envie de faire de betisse...)
    Je continue mes recherche...
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Stouf le Sam 28 Mar 2009 - 21:08

    cela veux bien dire que tu coche la case Système, que tu décoches toutes les cases sauf vitesse d'horloge du CPU...
    puis tu coches selement les cases processeur et GPU dans températures ?
    C'est bien ca... Autre chose, je vois que tu es sous Vista 64. Il est possible que tu aies à jouer un peu avec les paramètres 'stabilité' d'Everest... J'ai activé le minimum sous Trust, mais il est possible que Vista fonctionne différemment. Mais ca fonctionne, puisque j'ai commencé à déveloper le PipBoy sous Vista.

    Sinon, une fois le script en erreur, tu pourrais essayer de passer manuellement sur une autre page (mode1.clock par exemple) directement dans la page d'édition de LCDHype. C'est peut etre betement le code de control d'erreur qui deconne sous Vista, mais j'en doute Wink

    Pour setfsb, on utilise le pll ICS9LPR604AGLF, avec une valeur de 238 (sous XP)
    avatar
    johnat

    Maltraiteur de Betas

    Nombre de messages : 534
    Age : 29
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par johnat le Sam 28 Mar 2009 - 21:32

    Comment fait on pour passer en mode manuel ?
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Stouf le Sam 28 Mar 2009 - 22:21

    Tu ouvres la fenetre de lcdhype, tu vas dans la page d'edition du script, et en haut a gauche tu pourras voir toutes les pages composant le script. Tu as juste à double cliquer sur l'une d'elle pour la lancer.

    Mais fais attention quand même, car certaines fonctions sont déclarées une seule fois au lancement du script (en particulier la page core). C'est d'ailleurs dans cette page core, vers la fin, que se trouve la fonction de lancement/controle d'Everest/Fraps. Tu devrais pouvoir la supprimer/modifier sans trop de probleme, si c'est elle qui pose probleme...
    avatar
    johnat

    Maltraiteur de Betas

    Nombre de messages : 534
    Age : 29
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par johnat le Sam 28 Mar 2009 - 22:52

    Bon j'ai coché tout les cases dasn application externe > système plus les trois cases au dessus... et sa marche !!!
    Comprend pas trop pour l'instant... je vasi essayer diffrérente config pour savoir qu'elle est le paramètre qui joue...
    mais bon maintenant que sa marche je suis super content !!!
    c'est de la bombe se petit soft !!
    je kiff grave... la je suis en train de fair un teste de stabilité du nouveau driver 182.47 en 120... et cpu à 2.8... je monte pour l'instant (grave à la visualisation de pipboy) à 85°c max... apre sle ventillo se met à fond... et la je suis à 81°c...
    C'est vraiment super comme soft.... tu es trop fort !!
    manque plus que l'on puisse overcloker le cpu à la volé...

    aussi, moi j'utilise foobar comme lecteur de music (winamp est trop lourd... ce n'est qu'un avis)
    a ton avis est ce que c'est possible d'utilsier les fonctionnalité de winamp avec foobar ? et qu'elle serait les manip ?
    C'est jsute une sujection... je vasi pas mourir parce que je ne vois pas se que j'écoute...
    encore merci
    plus john
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Stouf le Sam 28 Mar 2009 - 23:17

    La comme ca pour Foobar, je pourrai pas du tout te dire si c'est possible, et encore moins comment faire ^^

    Mais je suis content que ca fonctionne, et content que ca te plaise... Smile

    L'OC du CPU à la volée... ca arrive, mais je sais pas encore exactement pour quand ^^
    avatar
    johnat

    Maltraiteur de Betas

    Nombre de messages : 534
    Age : 29
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par johnat le Sam 28 Mar 2009 - 23:44

    BOn je me suis mis à winamp (pas si mal optimisé que sa...)
    et j'ai un petit beuge...
    Parfois il n'affiche pas le nom de la chanson.. mais apparemment c'est normale..
    mais aussi, j'ai eu le droit a un redémarrage de pibboy comme sa en plein milieu..et il veux plus passer en mode lecture de music...
    étrange dit tu ?
    je redemande le pip et je te dit quoi...
    edit : en faite c'est le pluding qui ne démarer pas automatiquement... faut faire une manip sup ?
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Stouf le Sam 28 Mar 2009 - 23:52

    ahem... Pour tout te dire, j'ai arreté d'utiliser Winamp, car je n'arrivais pas a faire fonctionner le plugin comme je le voulais. Des fois il demarre automatiquement, des fois pas, bref...
    Je te dirai même qu'il n'est même plus installé chez moi, je suis passé a Songbird ^^

    La partie Winamp du script n'est plus la que de facon 'historique' je dirai, même si elle fonctionne à peu près ^^
    avatar
    johnat

    Maltraiteur de Betas

    Nombre de messages : 534
    Age : 29
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par johnat le Dim 29 Mar 2009 - 0:03

    C'est domage parcequ'il n'ya que cette histoire de pluging.. sinon c'est super pratique... tu m'as fasi revenir à winamp...et j'en suis tres content... il y a peux être dans les autres utilisateurs quelqu'un qui touche un peu plus sur se sujet... ouvre un topic au pire...
    parce que il a vraiment un intérêt se truc... bon moi je dit sa mais je ne sais même pas comment sa fonctionne... je peux même pas aider... faudrait que je regarde un peu plus en profondeur...

    Sanka

    Graine de développeur

    Nombre de messages : 29
    Age : 36
    OS Principal : Vista
    Script OLED : Sanka

    Re: PipBoy2 Beta 1

    Message par Sanka le Dim 29 Mar 2009 - 11:07

    C'est bizarre chez moi aucun problème au niveau du plugin/script ! En revanche c'est vrai que la version 5.5 de winamp est lourde et manque cruellement de stabilité... Il plante régulièrement au bout de quelques heures.

    Par contre sur mon script l'écran winamp n'est pas un pop up, peut-être que le problème viendrait de là ?
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Stouf le Dim 29 Mar 2009 - 18:19

    Il n'y a pas de raison, puisque en réalité les popups n'en sont pas vraiment : un évenement déclenche un changement de page, c'est tout.

    Par contre je confirme que les dernieres moutures de Winamp sont carrément instables (ma bibliotheque de 30Go s'ouvre une fois sur 10, la plupart du temps il ne trouve même pas les fichiers. Et ca va de plantage en plantage... Donc je laisse tomber pour le moment Winamp, et je reste sous SongBird Very Happy

    Sans vouloir faire de pub, Songbird c'est vraiment autre chose (les modules GetLyrics et GetParts, quelle aubaine pour un musicien ^^)
    avatar
    johnat

    Maltraiteur de Betas

    Nombre de messages : 534
    Age : 29
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par johnat le Dim 29 Mar 2009 - 21:28

    Dit pour winamp...j'ai remarqué qu'il était possible de lancer le pluging en tapant la combinaison suivante : ctrl + maj + K, ne serait il pas possible d'integer dans le script une ligne simulent la frappe de cette combinaison lorsque winanm se lance ?
    J'y connais rien moi, me taper pas si j'ai dit une betisse... je propse juste...
    sanka, en quoi ton script et différent de celui de stouf ? peux tu m'en dire un peu plus ?
    avatar
    Stouf

    Chef des rebelles

    Nombre de messages : 1357
    Age : 37
    OS Principal : Seven
    Script OLED : Autre script LCDHype

    Re: PipBoy2 Beta 1

    Message par Stouf le Dim 29 Mar 2009 - 22:19

    Non, c'est pas possible à ma connaissance de simuler des raccourcis clavier avec LCDHype. Par contre c'est possible avec AutoHotkey...

    Sanka

    Graine de développeur

    Nombre de messages : 29
    Age : 36
    OS Principal : Vista
    Script OLED : Sanka

    Re: PipBoy2 Beta 1

    Message par Sanka le Dim 29 Mar 2009 - 22:50

    johnat a écrit:
    sanka, en quoi ton script et différent de celui de stouf ? peux tu m'en dire un peu plus ?

    La différence, c'est que moi j'appelle l'affichage de winamp sur l'OLED en navigant parmi les menus de mon script, ce n'est pas une fonction qui fait s'afficher l'écran quand elle repère que winamp est lancé. Mais comme l'a dit Stouf, ça revient exactement au même, c'est la même ligne de commande qui appelle l'écran suivant...
    Mais vu qu'il y a plusieurs programmes surveillés pour faire appel aux pop ups, je me disais que peut-être il y avait un conflit quelque part, car en cas d'appel à deux pop ups simultanément, il faut créer des priorités... Et donc c'est peut-être à ce niveau que ça plante...
    Mais sinon je me suis dit autre chose, qui finalement serait plus probable : j'utilise la version 6.0.5 de Winamp, alors que Stouf est sur la version 6.1.3. Or la release officielle (d'après l'auteur du programme) est la 6.0.5... Je suppose donc que la 6.1.3 doit présenter des problèmes de stabilité.

    Stouf pourrais-tu m'envoyer ton script MSN et ton script Winamp afin que je les teste sur ma version de LCDHype, comme ça au moins on sera fixés Wink

    Contenu sponsorisé

    Re: PipBoy2 Beta 1

    Message par Contenu sponsorisé


      La date/heure actuelle est Mer 24 Mai 2017 - 23:23